FIBONOCCI DİZİSİ ve FIBONACCI HESAP MAKİNASI

FIBONOCCI DİZİSİ ve FIBONACCI HESAP MAKİNASI

Her sayının kendinden öncekiyle toplanması sonucu oluşan bir sayı dizisidir. Bu şekilde devam eden bu dizide sayılar birbirleriyle oranlandığında altın oran ortaya çıkar, yani bir sayı kendisinden önceki sayıya bölündüğünde altın orana  gittikçe yaklaşan bir dizi elde edilir

Fibonacci sayı dizisindeki sayıların birbirleriyle oranı olan ve altın oran denilen 1,618 sayısı ise doğada, sanatta ve hayatın her alanında görülen ve estetik ile bağdaştırılan bir sayıdır.

Altın oran, Fi (phi) sayısı olarak bilinir. Neticede matematiksel bir kavramdır ve değeri de 1,618 dir. Fibonacci sayıları ve altın oran matematiğin en ilgi çekici konuları arasındadır. Leonardo Fibonacci 13. yüzyılda yaşamış bir İtalyan matematikçisi tarafından ortaya atılmıştır.

KAYNAK: wikipedia.org/wiki/Fibonacci_dizisi

 

Excel’de hesaplanması:

A1 Hücresine 0 değerini yazalım;
A2 Hücresine 1 değerini yazalım;
A3 Hücresinede şu formülü yazalım =A1+A2 veya =TOPLA(A1+A2) ENTER dedikten sonra;
A3 Hücresine tıklayalım ve hücrenin sağ alt köşesinden aşağıya doğru sürükleyerek istediğimiz kadar fibonacci dizisinden sayı üretelim.

Aşağıdaki formülü de kullanabiliriz:

D1 hücresine;

=IF(ROW(A1)=1;0;IF(ROW(A1)=2;1;SUM(OFFSET(A1;-2;0);OFFSET(A1;-1;0))))

yazıp aşağıya doğru çekeriz.

Ya da ;

G2 hücresine KTF  =fib(ROW(A1)) aşağıya doğru çekelim.

Fibonacci sayıları arasındaki oranı (altın oran) bulmak için;
1- B2 Hücresine =A3/A2 yazalım ve ENTER’a basalım.
2- B2 Hücresine tıklayalım ve hücrenin sağ alt köşesinden aşağıya doğru sürükleyerek istediğimiz kadar fibonacci dizisinin sayılarının oranını bulalım.

Burada görülecek ki; 25.terimden itibaren oran sabit kalacaktır 1,618033989.

fibo

Dosya:

fiboneccih

 

You may also like...

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Şu HTML etiketlerini ve özelliklerini kullanabilirsiniz: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>